简体中文
简体中文
English
联系我们
注册
登录

3.14.x 升级说明

更新时间:2021-12-15 07:35:30下载pdf

如果您已经集成了之前的版本,要升级到 3.14.x 版本请参照如下步骤:

更新 tuyasmart 库的版本为 3.14.x 对应的版本。

  1. 移除 paho mqtt 库的依赖。

    implementation 'org.eclipse.paho:org.eclipse.paho.client.mqttv3:1.2.0'
    

    3.14.x 升级说明

  2. 移除 paho 库的混淆规则。

    -keep class org.eclipse.paho.client.mqttv3.** { *; }
    -dontwarn org.eclipse.paho.client.mqttv3.**
    

    3.14.x 升级说明

  3. 新增混淆规则。

    #mqtt
    -keep class com.tuya.smart.mqttclient.mqttv3.** { *; }
    -dontwarn com.tuya.smart.mqttclient.mqttv3.**
    
  4. 升级 okhttp 依赖库版本。

    implementation 'com.squareup.okhttp3:okhttp-urlconnection:3.12.3'
    

    修改 okhttp 混淆规则。

    #OkHttp3
    -keep class okhttp3.** { *; }
    -keep interface okhttp3.** { *; }
    -dontwarn okhttp3.**
    
    -keep class okio.** { *; }
    -dontwarn okio.**