文档中心

搭建 MCU 环境

更新时间:2020-10-17 13:48:52下载pdf

本文以 ST Nucleo 开发板为例,介绍 Windows 系统中 ST Nucleo 开发板的环境搭建过程。Mac OS 和 Linux 系统同时支持以下方案,但具体操作界面会有一定差异。

背景信息

涂鸦三明治开发套件中的主控板支持以下两款标准制造开发板:

  • ST Nucleo

    ST Nucleo 采用 STM32Nucleo-G071RB 为主控,其开发方式完全兼容 Arduino,因此在使用ST Nucleo开发板开发时,您不仅需要安装 Arduino IDE,还需要额外安装 STlink 驱动。

  • Arduino UNO

    Arduino 是全球最流行的开源硬件,也是一个优秀的硬件开发平台。Arduino 简单的开发方式使得开发者更关注创意与实现,更快的完成自己的项目开发,大大节约了学习的成本,缩短了开发的周期。有关 Arduino UNO 开发环境的搭建,您可以参考 Arduino 官方教程 自行操作。

操作步骤

第一步:安装 STlink 驱动

  1. 前往 Arduino 官网 下载 Arduino IDE。

    Arduino IDE 是用来编写 Arduino 程序的软件,将程序编写好后,就可以通过此软件上传到涂鸦三明治开发板。

  2. 前往 STMicroelectronics 官网 为 Windows 系统下载 STlink 驱动。

  3. 以管理员权限安装运行 STlink 驱动。

  4. 将 Micro-USB 线连接电脑与开发板,打开电脑设备管理器出现下图端口显示,表明驱动安装成功。

    注意:Micro-USB 线必须拥有数据传输功能。

    搭建 MCU 环境

第二步:配置 Arduino IDE

涂鸦三明治 ST Nucleo 开发板主控为 STM32Nucleo-G071RB,该型号在 Arduino IDE 中默认未支持,因此您需要通过以下操作使 Arduino IDE 支持开发板。

  1. 进入 Arduino IDE,在菜单栏,选择 文件 > 首选项

    搭建 MCU 环境

  2. 在红框位置填入 https://github.com/stm32duino/BoardManagerFiles/raw/master/STM32/package_stm_index.json,单击

    搭建 MCU 环境

  3. 在菜单栏,选择 工具 > 开发板 > 开发板管理器

    搭建 MCU 环境

  4. 在搜索框内输入STM32,单击 安装 开始安装相应开发板的板载包。

    搭建 MCU 环境

第三步:配置开发板

开发板安装完成后,开发者可根据自身开发板类型选择相应的型号,涂鸦三明治开发板在 Arduino IDE 内类型显示为 Nucleo-64,型号显示为 Nucleo G071RB。所以我们进行如下配置。工具栏内其余选项可保持默认配置(推荐),也可以根据需求自行更改。

  1. 进入 Arduino IDE,在菜单栏,选择 工具 > 开发板

  2. 选择芯片型号 Nucleo-64

    搭建 MCU 环境

  3. 在菜单栏,选择 工具 > Board part number,然后选择具体型号:Nucleo G071RB

    搭建 MCU 环境

  4. 在菜单栏,选择 工具 > Upload method,然后选择下载方式 STM32CubeProgrammer(SWD)

    搭建 MCU 环境

  5. 在菜单栏,选择 工具 > 端口,然后选择程序下载端口。您可以根据开发板与自身电脑连接选择相应的端口。

    搭建 MCU 环境

第四步:下载 STM32CubeProgrammer

涂鸦三明治开发套件采用 STM32Nucleo-G071RB 为主控,因此使用 Arduino IDE 编写 STM32 代码时,需要额外下载 STM32CubeProgrammer 软件,才能将代码下载到开发板中。

  1. 前往 STMicroelectronics 官网 为 Windows 系统下载 STM32CubeProgrammer 软件。

    说明:如果是 Mac OS 和 Linux 系统,您需要下载不同适配系统的 STM32CubeProgrammer 软件 来安装驱动。

  2. 安装完成后,将该软件安装路径下的 bin 文件路径添加到系统环境变量中。

    1. 打开控制面板,选择 系统和安全 > 安全,单击左侧导航栏的 高级系统设置

      搭建 MCU 环境

    2. 在弹出的 系统属性 窗口中,切换到 高级 页签,选择 环境变量

      搭建 MCU 环境

    3. 根据页面提示,新增一个环境变量。

      搭建 MCU 环境

      搭建 MCU 环境

执行结果

至此,涂鸦三明治开发板开发环境搭建完成,您可以在 Arduino IDE 中编写应用代码并下载到开发板中。

点击获取服务和帮助